BlogBeware of KDevelop Master and KDELibs 4.5.1 or lower Syndicate content

Wed, 09/08/2010 - 17:57

Hey all,

please don’t use KDevelop master with KDELibs 4.5.1 or lower. Katepart in that version misses a crucial commit that makes KDevelop crash. It is fixed for 4.5.2. In the meantime you have on of the following options:

  1. Build kate from sources
  2. Switch to the stable branches, i.e.: KDevplatform 1.1, KDevelop 4.1, PHP 1.1, …
  3. wait for the 4.5.2 release

bye

Comments

I tried to backport that Fri, 09/10/2010 - 00:13 — mosra (not verified)

I tried to backport that crucial commit to kdelibs 4.5.1 and after ten hours of intensive testing when KDevelop had no crashes I can say that it works.

Patched kdelibs package for ArchLinux users (and maybe inspiration for other distros) is here: http://mosra.cz/blog/article.php?a=9-patched-kdelibs-for-running-kdevelo…

Isn’t kdevelop 4.0 the stable Thu, 09/09/2010 - 16:26 — Anonymous (not verified)

Isn’t kdevelop 4.0 the stable branch? (not 4.1)

4.1 is the new stable branch Fri, 09/10/2010 - 16:16 — Milian Wolff

4.1 is the new stable branch as we will release the next stable version of it. 4.0 is even more stable but abandoned, it won’t see any more work. We are concentrating on 4.1 now.

Post new comment

  • You can use Markdown syntax to format and style the text. Also see Markdown Extra for tables, footnotes, and more.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <pre>.
  • Web page addresses and e-mail addresses turn into links automatically.

More information about formatting options